As of May 3, 2018 ABILITY | SECUREPAY™ (formerly Secure Bill Pay) will no longer support TLS 1.0 connections from web browsers. ABILITY | SECUREPAY users, and patients paying online, must use web browsers that support TLS 1.1 or TLS 1.2 protocol.

This protocol is an online, industry-wide PCI mandate that effects all web browsers. Any patient or user still using TLS 1.0 will not be able to use online patient payment tools.

Download the PDF for information to update your TLS settings.
Download TLS Requirement PDF

You may proceed to login below in the same browser window.
Proceed to Login