Home Browsers

Browsers

Supported browsers and health check guide

NEWER BROWSERS PROVIDE THE SECURITY YOU NEED

Even if the internet browser you use at your organization seems to be working correctly, it’s important to stay current with updates as they are released. Best practices in the healthcare industry say that in order to maintain the highest levels of security for your patient data and remain HIPAA-compliant, you should be using a browser that defaults to the latest security standards such as TLS 1.2 and above. Only newer browsers provide the level of security that today’s data transfers require.

View a full list of supported browsers by application in the Products and Browsers section below.


TAKE A HEALTH CHECK OF YOUR BROWSER

If you’re using Internet Explorer (IE), go to these two websites for a quick and easy check-up plus instructions on how to update to their latest, security-compliant browser, if needed:
Microsoft: Which operating system (OS) am I using?
Microsoft: Which version of Internet Explorer (IE) am I using?


If you want to use something other than Internet Explorer, you can choose one of the alternative options below:

ABILITY NETWORK TECHNICAL REQUIREMENTS

Operating Systems and Browsers
OPERATING SYSTEMS
AND VERSIONS
GOOGLE CHROME MOZILLA FIREFOX INTERNET EXPLORERMICROSOFT EDGE
Microsoft Window 10 Latest supported Latest supported N/ALatest supported

PRODUCTS AND BROWSERS

Firewall/networking: Ports 80 and 443 must be open for outbound access.
GOOGLE CHROMEMOZILLA FIREFOXINTERNET EXPLORERMICROSOFT EDGE
Portal user management:
Login
Dashboard
Configuration
Latest supportedLatest supportedLatest supportedLatest supported
Inside myABILITY code base:
AUTOMATE esMD
CHOICE All-Payer Eligibility
CHOICE Medicare Claims
CHOICE Medicare Eligibility
COMPLETE
INSIGHT
OPTIMIZE OASIS
Latest supportedLatest supportedLatest supportedLatest supported
Outside myABILITY code base:
EASE All-Payer
CAREWATCH
RISKWATCH
SECUREPAY
UBWATCH
ABILITY SMARTFORCE
Latest supportedLatest supportedLatest supportedLatest supported
Inside myABILITY code base:
EASE Medicare
Requires workaroundLatest supportedLatest supportedNot supported
Outside myABILITY code base:
IVANS NOW
Requires workaroundRequires workaroundLatest supportedNot supported
Outside myABILITY code base:
OPTIMIZE Analytics
OPTIMIZE (Hospice)
Requires workaroundLatest supportedLatest supportedLatest supported